Make your own free website on Tripod.com




Click image to enter

Browser compatibility:
Netscape 4.0+: You're ready to go!
Internet Explorer 4.0+: You're ready to go!
Netscape below 4.0: You can see the basic stuff, but getting a higher version will enhance your experience.
Internet Explorer below 4.0: Ditto.
AOL: Looks ok, but if you've got Netscape or Internet Explorer, use it.
Other browsers: To be perfectly honest, I don't know.
You do need frames to see much of anything. Netscape 4.0+ and IE 4.0+ are preferred! If you haven't understood a word after "Click image to enter," then email me and I'll set you straight.

Download the latest version of Netscape
Download the latest version of Internet Explorer